Running Reports using SAS Web Report Studio

Introduction

This document explains the key features of the SAS Web Report Studio (Web Report Studio)
reporting tool. It is not specific to any one report. There is a separate, supplemental
document for each Web Report Studio report that explains that report's purpose and filters.

A complete list of reports can be found on the Finance Reporting Reference Guide and
the HR/Payroll Reference Guide. The links to these documents are below:

e http://ccinfo.unc.edu/resource-docs/finance-reporting-reference-guide/

o http://ccinfo.unc.edu/tools/hr-reporting/

Sections in this Document

This document contains the following sections:

e Accessing Web Report Studio Reports in InfoPorte

e Running Web Report Studio Reports

o Working with the Report Output

e« Common Web Report Studio Commands

Accessing Web Report Studio Reports

Web Report Studio reports are located in different places in InfoPorte, depending on the
report's content. Always refer to the reporting guides for the navigation paths for each
report. The navigation paths to some commonly used Web Report Studio reports are below.

Example 1: OSR Campus Reports

Several Web Report Studio reports related to grants are located at this navigation path:
Finance > Dept Accounting > Grants > OSR Campus Reports

DTN aaelI[11i[s[s8 | Financial Reporting | | OSR Financial Repori

Ledaer Eallups § Transactions § GL Activity § Grants § oft Encumbrances

Grant Profile || OSR Campus Reports |

Click the link to open the report.

OSR Payments Report

This report displays all AR payment fransaction




Example 2: Payroll Accounting Report

The Payroll Accounting report is located at: Finance > Financial Reporting > Funding

Dept Accounting | BELEWSEULG gl .DSF{ Financial Reporting | | Financial Red

dlLedg'Ml(EEh.f E)! Misc b

Click the link to open the report.

Payroll Accounting Report

This report shows payroll expenses by financia

Running Web Report Studio Reports

Reset to Default

It is important to get in the habit of clicking the Reset to Default link at the top right
corner of the report each time you run a Web Report Studio report. Otherwise, the report
"remembers" the previous value you entered.

Reset to Default -

Search Filters

Most Web Report Studio reports have two or more filters. The home page of a report can
typically only display two filters at a time.

Get in the habit of scrolling down to make sure you see all the available filters. You only
need to complete the filters you want to run the report by.

Reset to Default .

m

-

Ifvou see a scrollbar,
itmeansthere are
mare filters below.




Search or Enter Values

Below is an example of a typical Web Report Studio report filter. For each filter, you need
to move the values you want to the Selected section. You have three options for searching
for values: the magnifying glass, scroll arrows, and the freeform field.

*%elect a Fund Codeis):

Available: 2 Rows 1-100 + & Selected:
{all possible values) Pl

jall possible values] &
10100-Gen Adm-Control Fuid
10118-Gen Adm-ARRA Race tr

10141-Gen Adm-UNC CPTV Use the magnifying glass,
; scroll arrows, freeform field
10142-Gen Adm-Community 5 e to search and select the

values youwant.
10144-Gen Adm-MCHC Contrz

10145-Gen Adm-MC Center fo
10157-Gen Adm-5alary Relate
10158-Gen Adm-Other Resen _

4 I 3

Using the Magnifying Glass

Follow these steps to use the magnifying glass to search and select values.

1. Click the magnifying glass.

*Select a Fund Code(s):
Available: O Rows 1-100 & & Selected:

LN | L1 1 A s

Results: The search window opens. There are two tabs at the top, Browse and Search.
The default is the Search tab, which allows you to search by specific values. The
Browse tab allows you to scroll through all the values.

2. Enter an alpha or numeric value in the search field.

Note: You can change the filter operand from Contains to Exactly matches, Starts with,
Ends with, and Matches pattern.

Ctherfilter
operands are
Search for iteins that:

Browse

Contains | Acad Calected:




3.

Click the Search button.

Search for items that:

Search jall possible values)

Browse Search

Contains - Acad electad:

o

Result: The values appear in the white space below the Search button. This is the
Available section. You need to move the values you want to the Selected section.

Browse Search

Search for items that:
| Containg hd | |.-fk-: ad |

Search | Selected:

(all possible values) >

20100-Acad Affairs - Gen Fund L
20101-Acad Affairs - Reg Term
20102-Acad Affairs - Sum Term Lf;
20103-Acad Affairs — Extention

4. Use one of the options below to move the values you want to the Selected section.

All possible values. Most of the time, "all possible values" appears by default in
the Selected section. If this is the case, and you want to show all values, you don't
need to do anything. Sometimes, however, "all possible values" only appears in the
Available section, in which case you need to select it and click the single arrow to
move it to the Selected section.

The double arrow. The double arrow is another way to select all values. It is
enabled on filters with a smaller number of values. A filter either has the "all
possible values" option or the double arrow option, but not both.

Selecting a single value. To select a single value, click the value and then click
the arrow in the space between the Available and Selected sections.

Selecting multiple values in a consecutive range. To select multiple values in a
consecutive range, press and hold the Shift key, select the values you want, and
click the single arrow.




« Selecting multiple values not in a consecutive range. To select multiple values
not in a consecutive range, press and hold the Ctrl key, select the values you
want, and click the single arrow.

Available: 22 F # Rows 101 - 2000f 320 &+ + Selected:
iall possible values) ot

21130-Health Affairs - 5tu Fin ~
21142-Health Affairs - Comm *.l—l
21151-Health Affairs - Librarie
21152-Health Affairs - Gen Ac
21157-Salary Reserve E
21158-Health Affairs - Othr R

5. Once you have moved the values you want to the Selected section, click the Select
button.

Selected:

20101-Acad Affairs - Reg Term In

20100-Acad Affairs - Gen F””lé 20102-Acad Affairs - Sum Term I
20101-Acad Affairs - Reg Terr 5 20103-Acad Affairs - Extention Ir
20102-Acad Affairs - Sum Ten £ (20105-Acad Affairs - School of G

20103-Acad Affairs - Extentio
20105-Acad Affairs - School o
2010%-Acad Affairs Federal AR
20110-Acad Affairs - Organize

4 I 3

Cance

Result: The system displays the values in the filter.

*Select a Fund Codels):

Available: 0 F # Rows 101 - 200 of 320 & % Selected:
20101-Acad Affairs - Reg Term | X |

20102-Acad Affairs - Sum Term |
20103-Acad Affairs - Extention |
20105-Acad Affairs - School of G

21130-Health Affairs - Stu Fin *
21142-Health Affairs - Comm ‘.I—I
21151-Health Affairs - Libraris
21152-Health Affairs - Gen Ac




Using the Scroll Arrows

Search fields with many values have single and double arrows that allow you to scroll
through the values quickly.

o The single arrows scroll up or down in increments of 100.
o The double arrows scroll to the first or last row.

e« When you find a value you want, follow the guidelines from the Using the
Magnifying Glass section to select and move the value to the Selected section.

*gelect a Fund Codeis):

Available: 2 - Rows 1-100 + £ Selected:
jall possible values) -~

jall possible values) &

1M AN-Gan Admanntral |:||r|r||_|

Using the Freeform Field

1. To use the freeform field, enter the value you want in the field.

2. With the value selected, click the single arrow.

i | 1] [ b

20101 B

Result: The system displays the value in the Selected field.

Caution! The "all possible values" entry remains even after you select a value from
the freeform field. You need to manually remove it by selecting it and clicking the X

button.
*8elect a Fund Codei(s):
Available: 2 ¢ Rows1-100 & £ Selected:
all possible values -~
iall possible values) n (alp ) J
(T me
10100-Gen Adm-Control Fund —

Removing Values

To remove a value from the Selected section, highlight the value and click the X icon.

Available: 0 F ¢ Rows 101 - 200 of 320 &+ & Selected:
{all possible values) .

21130-Health Affairs - Stu Hn +
21142-Health Affairs - Comm !l—l

21151-Health Affairs - Librarie




Viewing the Report

When you have entered the report filters you want, click the View Report button.

Results:

The system displays the report.

Working with the Report Output

Below is an example of the output of a Web Report Studio report.

Contract & Contract 5tart Date Contract End Date Contract Status Bill Type ID Bill Cycle 1D Award Milestone Type Milestone O
1 ADD-D001-001 O1-JUL-2006 A0-JUN-200T CLOSED LOC LOC FINAM FROE RFT
2 ADD-0DIZ-001 O1-APR-2006 31-MAR-200T CLOSED LOC LOC FINAM FROE RFT
3 ADD-0DI2-001 O1-APR-2006 I-MAR-200T CLOSED LOC LOC FINAM FROE RFT
4 ADD-0DIZ-001 Q1-APR-2006 31-MAR-200T CLOSED LOC LOC FINAM FROE RFT
5 ADD-0DI2-001 O1-APR-2006 I-MAR-200T CLOSED LOC LOC FINAM FROE RFT
6 ADD-0DIZ-001 O1-APR-2006 31-MAR-200T CLOSED LOC LOC FINAM FROE RFT
T ADD-0DI2-001 O1-APR-2006 I-MAR-200T CLOSED LOC LOC FINAM FROE RFT
8 ADD-0DIZ2-001 O1-APR-2006 31-MAR-200T CLOSED LOC LOC FINAM FROE RFT
9 ADD-0DI3-001 15— MAR-2006 3-AUG-2010 CLOSED LOC LOC
10 ADD-D004-001 01-MAR-200G I1-JAaN-2012 CLOSED LOC LOC FINAM FROE RFT
11 ADD-0D04-001 Q1 MAR-Z2006 I-JaN-2012 CLOSED LOC LOC FINAM FROE RFT
12 ADD-D004-001 01-MAR-200G I1-JAaN-2012 CLOSED LOC LOC FINAM FROE RFT
13 ADD-0005—001 01— MAY—2006 1-MAR-2011 CLOSED LOC LOC FINAM FROE RFT
14 ADD-DD0E-D01 Q1WA —2006 I1-MAR-2011 CLOSED LOC LOC FINAM FROE RFT
15 AON-OWNE-NT 0l &N R 21— & D11 C1OSED Lo L™ Elh &R EBRNE BET

Column Headers

Right click on any column header to display options for sorting, moving columns, and
aligning the data.

Contract &4 Contract Start Date Contract End Date Contract S=hu=_Bill Tena I Bill Cucla 10 A
AD0-0001-001 01-JUL-2008 20-JUN-2007 closEp | 24 Sort Ascending FlMy
ADD-0002-001 01-AFR-2006 31-MaR-2007  cLoseD |54 Sort Descending FINy
A00-0002-001 01-APR-2006 31-MAR-2007  CLOSED Remove All Sorting FINy
A00-0002-001 01-APR-2006 31-M&R-2007  CLOSED FINy
ADD-0DD2-D01 01-APR-2006 31-MAR-2007 CLOSED Move to Left FIM
A00-0002-001 01-APR-2008 31-MAR-2007  CLOSED Move to Right FIny
A00-0002-001 01-APR-2006 31-MAR-2007  CLOSED : - FINy
ADO-0002-001 01-APR-2008 21-MAR-2007  CLOSED Align Left FIN
ADD-0DD3-D01 18-MAR-20068 31-ALG-2010 CLOSED Align Right
ADD-0004-001 01-MAR-2008 I1—JAN-2012 CLOSED Align Center FIny
AD0-0004-001 01-MAR-2008 31-JAN-2012 CLOSED : FINy
ADD-0004-001 01-MAR-2006 I1—JAN-2012 cLosep | o Hide Contract Status |-,
ADO-0005-001 01-MAY—2008 1—MAR-2011 CLOSED LOC LoC FINy




Edit Menu

Right click in any cell of the report to open a menu with options for arranging and
analyzing the data. The table below defines the options in the menu.

In this field:

Do the following:

Assign Data

Sort Priority

Total

Percent of Total

Filter and Rank

Conditional
Highlighting

Export Table

Rotate Table

Data Source Details

Allows you to change the order of the columns, or hide a column. After
you click on Assign Data, select the column you want to move, and use
the Move Item button to move the item up or down.

Allows you to select the columns to sort the data by.

Sums columns with numerical values. The sum appears in a Total row
at the bottom.

Shows the percent of a value to the total of the values in that column.
The percent shows in a new column. When adding the Percent of Total,
the "Label" field is what you want the column header to be.

The rank option is not used for the reports currently available in Web
Report Studio. To filter, after you select the Filter and Rank option,
select the field you want to filter by.

Allows you to color-code cells and text. After clicking Conditional
Highlighting, select the New button and select cells and colors. When
you click OK, the report appears with the highlights you entered.
This exports the data view to Excel.

Note! Clicking File > Export from the top toolbar in the report exports
the full data set to Excel, not just the view in front of you.

Switches the column headers to row headers, and vice versa.

Field details of the page.

Properties Format details of the report.

Contract &  Contract 5tart Date Contract End Date Contract Status Bill Type ID Bill Cycle I Award Milestone
AD0D-0001-001 O1-JUL-2008 30-JUN-2007 CLOSED LOC LOC FlMAN
AD0-D002-001 D1-APR—2008 31-MAR-2007 CLOSED Loc | B Assign Data ...
ADD-0002-001 01-APR-2008 31-MAR-2007 CLOSED LOC Sort Priority ...
AD0-0002-001 01-APR-2008 31-MMAR-2007 CLOSED LoG | Bl Total ...

AD0-0002-001 01-APR-2008 31-MAR-2007 CLOSED LOC Percent of Total ...
AD0D-0002-001 O1-APR-2008 31-MAR-2007 CLOSED LOC| %7 Filter and Rank ...
ADD-0002-001 01-APR-2008 31-MARM2007 CLOSED oG

AD0-0002-001 01-APR-2008 31-MAR-2007 CLOSED LOC @ Conditional Highlighting ...
Ann_nnna_nn‘l AR_RAAD_WNR QA Al WZ_WiI4Nn El DSED LDE L‘T E_xpl:lr_t Tal:lI.E .
ADD-0004-001 CLOSED LOC

AD0-0004-001 ¢ FoDU0T 0 i ot CLOSED LoC Data Source Details
ADD-0004-001 01-MAR-2008 31-JAN-2012 CLOSED LOC Properties




Common Web Report Studio Commands

The top left toolbar in Web Report Studio reports have common commands for working with
the file. The table below defines these commands.

In this field: Do the following:

File The File menu contains the following options:

o Open - allows you to open another report in Web Report Studio.

o Open Recent - allows you to open a report in Web Report Studio
that you've recently had open.

o Close - allows you to close the report
« Export - allows you to export the entire data set to Excel.

o Note: This is different from exporting just a particular view of
the report, which you do by right clicking in a report output and
clicking Export.

o Comments is not used.

o Page Setup - allows you to manipulate the page layout
o Print - allows you to print the report

o Manage Files is not used.

o Properties - shows the report properties

View The View menu contains the following options:

e Section - not used

o Applied Filters - you can remove or select the filters you used to
run this instance of the report

o Data Panel - hides or disples the left panel

« Report Style - contains various display options

Data > Refresh Data | Allows you to refresh the data and run a new instance of the report.

Open icon Equivalent to the File > Open menu option.
Print icon Equivalent to the File > Print menu option.
Export icon Equivalent to the File > Export menu option.
= ey I

File View Data [ = [IF
= Open ... «

Open Recent »

Cloze
[(# Export ... -

Comments ...




Report Views

In the top right corner, there is a ratio, such as 1/1. This indicates how many pre-formatted
views are available for the report. It is equivalent to the number of options in the table of
contents to select.

|Tn| Indicatesthe number of
pre-formatted views for
the report. Equivalent to

| View Report | thenumber of options in

the table of contents.

Reset to Default .
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